Home » ruby on rails » rails5 windows環境でExecJS::ProgramErrorのエラーがでてしまう

rails5 windows環境でExecJS::ProgramErrorのエラーがでてしまう



環境 
Ruby2.3.3
Ruby on Rails5.1.4
OSwindows10
windows環境でRailsをサーバーを起動して、 ページにアクセスしようとすると ExecJS::ProgramError や TypeError: オブジェクトでサポートされていないプロパティまたはメソッドです。 などのエラーの内容が表示されてしまいます。 gem 'coffee-script-source', '~> 1.8.0' のgemを入れたところ、エラーが解消されました。 ※バージョンが1.8.0以外はエラーになります。 gemを追加します。
gem 'coffee-script-source', '~> 1.8.0'

gemをrailsに入れていきます。

bundle update coffee-script-source

入れるとエラーは解消されるとおもいます。

,

コメントを残す

%d人のブロガーが「いいね」をつけました。